Hello and welcome to our community! Is this your first visit?
Register
Page 7 of 7 FirstFirst ... 567
Results 61 to 64 of 64
  1. #61
    Bananas! Chimp's Avatar
    Join Date
    Sep 2019
    Location
    The Jungle
    Posts
    94
    Likes (Given)
    14
    Likes (Received)
    55
    The adaptors are still available from ffsystems so should still be doable? I've just taken a punt on a "200m 20000lm" unit from China. Even allowing for conversion from Chinese lumen it should still be much brighter than the old tristar I've got now.
    Believe it or not, bananas do contain a small quantity of Musa Sapientum bananadine, which is a mild, short-lasting psychedelic

  2. #62
    Established TDF Member witchieblackcat's Avatar
    Join Date
    Dec 2012
    Location
    Penwortham
    Posts
    1,902
    Likes (Given)
    1762
    Likes (Received)
    582
    Quote Originally Posted by barnaby_s View Post
    Don't HID bulbs need a lot of power to get started, and then less to keep running, so it might make sense that it struggled with an HID if it had been designed for a halogen.
    LED generally use less power than an equivalent halogen and don't need that kick to get started so may work better with an old battery pack.
    Yes, it's the power requirement necessary to get the HID started that was the problem.
    The F2 battery ought to have the right amount of grunt to do it though (and we'd checked that).
    Apparently, the F2 battery wasn't as good as it was when it was new.

    Not sure if we tried it with another similar vintage battery which did work or not.

  3. #63
    TDF Member
    Join Date
    Dec 2012
    Posts
    278
    Likes (Given)
    46
    Likes (Received)
    103
    Anyone know if its possible to get GF umbilical cables repaired or reconditioned. I have two that don't work anymore.

  4. #64
    Established TDF Member MikeF's Avatar
    Join Date
    Dec 2012
    Location
    Darkest Aberdeenshire
    Posts
    3,938
    Likes (Given)
    209
    Likes (Received)
    2873
    they come apart fairly easily. probably a broken wire at the cable entry, if so trim it back and solder it back on.

    https://www.candlepowerforums.com/vb...orce-umbilical

    or speak to lumb bros


 
Page 7 of 7 FirstFirst ... 567

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •