Hello and welcome to our community! Is this your first visit?
Register
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Established TDF Member steelemonkey's Avatar
    Join Date
    Dec 2012
    Location
    Too far from the sea!
    Posts
    9,508
    Likes (Given)
    2643
    Likes (Received)
    5512

    Calling for an auto electrician.

    I have a transit 110 T300 2007 plate.
    The story so far. It is a campervan so has been sitting around quite a bit.
    The battery got low, got enough power to open doors etc but not enough to start the motor.
    I put it on charge overnight, not disconnecting the battery, don't know if that is relevant.
    Started it the next day and took it for a run to warm it up well as it had not been started for some time.
    Found out that all the dashboard instruments were dead, speedo, rev counter, fuel gauge and temp gauge. The radio was lighting up but not working. Presumed a fuse had gone. Also found that it did not start every time, the key turns but the starter does not work. I can hear clicking from passenger side.
    Today I squirted WD 40 into the ignition lock in case there is a spot of corrosion, also found the instrument fuse which had not blown.
    Now it gets weird. The starter is still intermittent, the fuel gauge came on for a bit and then went off again and I have found that the radio works with the ignition off but not with it on.
    So, is it a dodgy ignition switch, a wonky relay, another fuse somewhere, something else or a combination of all three?
    Do I need to stop faffing about and get an auto electrician to look at it?
    TIA.
    Paul.
    If God had meant us to breathe underwater, he would have given us larger bank balances.
    Human beings were invented by water as a means of moving itself from one place to another.

  2. #2
    Formerly sbc23cam Steve Clark's Avatar
    Join Date
    Dec 2012
    Location
    Preston, UK
    Posts
    2,650
    Likes (Given)
    251
    Likes (Received)
    1709
    My transit went totally bananas when moisture got inside the body control module. I had someone do a track repair on the pcb to fix some corrosion and now it is wrapped in a quilt of silica gel packets.

  3. #3
    Established TDF Member steelemonkey's Avatar
    Join Date
    Dec 2012
    Location
    Too far from the sea!
    Posts
    9,508
    Likes (Given)
    2643
    Likes (Received)
    5512
    Quote Originally Posted by Steve Clark View Post
    My transit went totally bananas when moisture got inside the body control module. I had someone do a track repair on the pcb to fix some corrosion and now it is wrapped in a quilt of silica gel packets.
    Thanks, that's another thing to worry about.
    Paul.
    If God had meant us to breathe underwater, he would have given us larger bank balances.
    Human beings were invented by water as a means of moving itself from one place to another.

  4. #4
    TDF Member
    Join Date
    Jan 2013
    Location
    Berkshire
    Posts
    384
    Likes (Given)
    79
    Likes (Received)
    210
    Quote Originally Posted by steelemonkey View Post
    I have a transit 110 T300 2007 plate.
    The story so far. It is a campervan so has been sitting around quite a bit.
    The battery got low, got enough power to open doors etc but not enough to start the motor.
    I put it on charge overnight, not disconnecting the battery, don't know if that is relevant.
    Shouldn't be a problem.

    Quote Originally Posted by steelemonkey View Post
    Started it the next day and took it for a run to warm it up well as it had not been started for some time.
    Found out that all the dashboard instruments were dead, speedo, rev counter, fuel gauge and temp gauge. The radio was lighting up but not working. Presumed a fuse had gone. Also found that it did not start every time, the key turns but the starter does not work. I can hear clicking from passenger side.
    Do you have (or can you borrow) a voltmeter?
    Car batteries don't like sitting flat, it damages them. Sometimes putting them on charge (up to 14.5V) will revive them fully, sometimes not. It should be ~12V with ignition off and 13-14V running.

    Quote Originally Posted by steelemonkey View Post
    Today I squirted WD 40 into the ignition lock in case there is a spot of corrosion, also found the instrument fuse which had not blown.
    Now it gets weird. The starter is still intermittent, the fuel gauge came on for a bit and then went off again and I have found that the radio works with the ignition off but not with it on.
    So, is it a dodgy ignition switch, a wonky relay, another fuse somewhere, something else or a combination of all three?
    Do I need to stop faffing about and get an auto electrician to look at it?
    TIA.
    Probably. Does sound like a dodgy switch though, but worth checking the battery's healthy too.

    (I'm not an electrician, I'm an electronics engineer who mostly sits at a computer doing software and algorithm stuff these days)

  5. #5
    Pedantic Pig Divemouse's Avatar
    Join Date
    Dec 2012
    Location
    Suffolk
    Posts
    4,810
    Likes (Given)
    6604
    Likes (Received)
    3096
    Mice.
    hormone addled, protective, psychotic, hate filled killer

  6. #6
    I still don't have a member
    Join Date
    Dec 2012
    Location
    In my own world
    Posts
    2,643
    Likes (Given)
    785
    Likes (Received)
    856
    Quote Originally Posted by Divemouse View Post
    Mice.
    Gets my vote as well!!
    A fully paid up member of the CRAFT Club

    I failed to dive in Antartica
    I used to have a handle on life but it broke

  7. #7
    Gone diving back later Vanny's Avatar
    Join Date
    Jan 2013
    Location
    Essssssex
    Posts
    1,045
    Likes (Given)
    383
    Likes (Received)
    272
    My transit has 2 batteries. One dedicated to the starter and one for the dash/radio stuff. Think there both under the drivers seat. Yours maybe different mines a motorhome 2.4 140 GG’s. I also have a separate leisure battery but that doesn’t affect anything upfront. Possible you’ve got 2 ?? Ones dead or dying.

  8. #8
    Established TDF Member steelemonkey's Avatar
    Join Date
    Dec 2012
    Location
    Too far from the sea!
    Posts
    9,508
    Likes (Given)
    2643
    Likes (Received)
    5512
    Quote Originally Posted by cazyoung View Post
    Gets my vote as well!!
    Spoken from the heart.
    Paul.
    If God had meant us to breathe underwater, he would have given us larger bank balances.
    Human beings were invented by water as a means of moving itself from one place to another.

  9. #9
    Established TDF Member steelemonkey's Avatar
    Join Date
    Dec 2012
    Location
    Too far from the sea!
    Posts
    9,508
    Likes (Given)
    2643
    Likes (Received)
    5512
    Quote Originally Posted by Vanny View Post
    My transit has 2 batteries. One dedicated to the starter and one for the dash/radio stuff. Think there both under the drivers seat. Yours maybe different mines a motorhome 2.4 140 GG’s. I also have a separate leisure battery but that doesn’t affect anything upfront. Possible you’ve got 2 ?? Ones dead or dying.
    I have 2 leisure batteries but AFAIK only one for upfront stuff. That is under the drivers seat. I will follow Stigs advice and see if my voltmeter still works and if the battery is good I think I will change the starter motor relay as that is the cheaper/easier option. Next step, ignition switch.
    I was just hoping that some genius expert could narrow down the options for me.
    Paul.
    If God had meant us to breathe underwater, he would have given us larger bank balances.
    Human beings were invented by water as a means of moving itself from one place to another.

  10. #10
    Established TDF Member steelemonkey's Avatar
    Join Date
    Dec 2012
    Location
    Too far from the sea!
    Posts
    9,508
    Likes (Given)
    2643
    Likes (Received)
    5512
    The battery is showing 12.5V with engine off and 14.25 with it running so I am ruling that out.
    Paul.
    If God had meant us to breathe underwater, he would have given us larger bank balances.
    Human beings were invented by water as a means of moving itself from one place to another.


 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •