Hello and welcome to our community! Is this your first visit?
Register
Results 1 to 5 of 5

Thread: LFM problems.

  1. #1
    New TDF Member
    Join Date
    Jun 2019
    Location
    Liverpool
    Posts
    10
    Likes (Given)
    0
    Likes (Received)
    0

    LFM problems.

    My LFM NW7 has recently developed a fault. The cable appears to be faulty just behind the spring on the torch head. Quite a few people have advised me to repair it myself due to issue around the LFM repair service.
    Has anyone opened up their NW7/7XPE heads in order to replace the cable?

  2. #2
    Divey McDiveface Nickpicks's Avatar
    Join Date
    Dec 2012
    Location
    Dacorum
    Posts
    3,272
    Likes (Given)
    2181
    Likes (Received)
    1695
    I'd have a chat with DIR Direct / Underwater Explorers in Portland first - see what they can do to help.

    There is a thread on here about the DIY repair of an LFM 4TEC - I expect the construction / assembly of the NW7 is similar.

    https://www.thediveforum.com/showthr...)-torch-repair

    There are pictures in that thread, but they don't show for me unless I click "reply with quote", then paste the image urls into different browser tabs (this might be my company's ad blocker causing problems)

    (alternatively, ask @MadUKDiver to fix it for you - he seems to have experience )
    The major difference between a thing that might go wrong and a thing that cannot possibly go wrong is that when a thing that cannot possibly go wrong goes wrong it usually turns out to be impossible to get at or repair.

  3. #3
    TDF Member
    Join Date
    Sep 2017
    Location
    Royal Wootton Bassett
    Posts
    173
    Likes (Given)
    2
    Likes (Received)
    47
    Quote Originally Posted by Nickpicks View Post
    I'd have a chat with DIR Direct / Underwater Explorers in Portland first - see what they can do to help.

    There is a thread on here about the DIY repair of an LFM 4TEC - I expect the construction / assembly of the NW7 is similar.

    https://www.thediveforum.com/showthr...)-torch-repair

    There are pictures in that thread, but they don't show for me unless I click "reply with quote", then paste the image urls into different browser tabs (this might be my company's ad blocker causing problems)

    (alternatively, ask @MadUKDiver to fix it for you - he seems to have experience )
    I just did my Halcyon EOS primary myself, it was really easy to be fair but naturally a worry when you first start cutting!

  4. #4
    New TDF Member
    Join Date
    Jun 2019
    Location
    Liverpool
    Posts
    10
    Likes (Given)
    0
    Likes (Received)
    0
    Hi Nick. Thanks for the reply and the link. Iíve already contacted DIR Direct and they have been really helpful. Iíve also contacted another diver who had similar problems with his NW7 but the cable had gone at the ACCU end. Also in contact with LFM and up to now, they have responded immediately. Just undecided which way to go at the moment.

  5. #5
    New TDF Member
    Join Date
    Jun 2019
    Location
    Liverpool
    Posts
    10
    Likes (Given)
    0
    Likes (Received)
    0
    Thanks M-J-J. Thatís the big worry. Everyone is advising me to do it myself and Iíve got the skills to do it. Just donít want to make a stupid mistake though. 😬


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •